Installation

Dependencies

VIOLIN requires Python version 3.7 or higher, as well as the pandas and NumPy libraries.

Python can be installed from the Python website for Mac or Windows OS.

For Mac OSX, Python can also be installed at the command line by:

>> brew install python

Installing VIOLIN

A copy of the VIOLIN repository can be downloaded from the Bitbucket website at https://bitbucket.org/biodesignlab/violin/src/master/, or cloned through git at the command line:

>> git clone https://bitbucket.org/biodesignlab/violin/src/master/

You will then need to run the setup.py file to use VIOLIN as a package:

>> python setup.py install

VIOLIN GUI

Currently in development is a user interface for VIOLIN for inputting LEEs and models for a non-specified extension comparison. Check back soon for updates.